Ug EMR shows error message when I want to view some patient dashboards

Can run a concept dictionary and restart the instance first? Let me know if that doesn’t help out fix this

Hi @Cosmas, I hope you are comfortable with MySQL.
If so, go ahead and close pending client visits with this script.
Before running the script, head to cmd, type mysql -u root -p [press enter button]
type: openmrs [press enter button]
Then type use openmrs;
then copy and paste this script:

*update patient_queue set status ="COMPLETED" where status ="PENDING" and date_created < "2022-11-16"*;
[press enter button] and restart computer. :blush:
For future cases, always update the date in the script to today’s date


Thank you @tonycarter, Kindly take me through the process of running the concept dictionary in MySQL.

Hello @Cosmas, kindly follow the procedure as highlighted by @dopuch

Dear Dopuh and the rest of the EMR Community,
I have experienced the same problem at my site and tried to run that script. However, it has never worked out and I still have the same problem. I have over 20 clients affected by this issue. Thank you for your support.

@pamutungire this is unfortunate.
Can we arrange for remote support?
So we can improve this support thread.

Thank you Dopuch. It is well with me.

@pamutungire ensure you update the date to at least yesterday’s date. Also, you shouldn’t get an error when you run that script, in case of any errors, kindly share them here.

We would also like to know how you are running the script, a screenshot will provide good feedback

Thank you @nmayanja for the support. I have tried to run the script and the problem persists. Here is a screen shot of some number which keeps loading without a response. Another one shows the search results but can not open the patient dashboard.
Ps: I have also tried rebuilding the search index